Get webhook notifications whenever College of Charleston System Status creates an incident, updates an incident, resolves an incident or changes a component status.
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jun 27, 2025 - 15:00 EDT
Update
MarketPlace (eBill/TouchNet) & the housing online deposit portal (StarRez) will be unavailable for financial year-end processing starting on the afternoon of Friday, June 27 (3:00 PM) until the morning of Tuesday, July 1 (8:00 AM).
• The eBill (MarketPlace) & the My Housing/Dining (StarRez) tiles in MyPortal will redirect to College of Charleston outage page
All deposits for the Treasurer’s Office should be delivered no later than 3:00 PM on Friday, June 27th. No funds received should remain undeposited by June 27th. The Treasurer’s Office will be open starting at 8:30 AM on July 1st.
Posted Jun 26, 2025 - 16:29 EDT
Update
MarketPlace (eBill/TouchNet) & the housing online deposit portal (StarRez) will be unavailable for financial year-end processing starting on the afternoon of Friday, June 27 (3:00 PM) until the morning of Tuesday, July 1 (8:00 AM).
• The eBill (MarketPlace) & the My Housing/Dining (StarRez) tiles in MyPortal will redirect to College of Charleston outage page
All deposits for the Treasurer’s Office should be delivered no later than 3:00 PM on Friday, June 27th. No funds received should remain undeposited by June 27th. The Treasurer’s Office will be open starting at 8:30 AM on July 1st.
Posted Jun 26, 2025 - 16:27 EDT
Scheduled
MarketPlace (eBill/TouchNet) & the housing online deposit portal (StarRez) will be unavailable for financial year-end processing starting on the afternoon of Friday, June 27 (3:00 PM) until the morning of Tuesday, July 1 (8:00 AM).
• The eBill (MarketPlace) & the My Housing/Dining (StarRez) tiles in MyPortal will redirect to College of Charleston outage page
All deposits for the Treasurer’s Office should be delivered no later than 3:00 PM on Friday, June 27th. No funds received should remain undeposited by June 27th. The Treasurer’s Office will be open starting at 8:30 AM on July 1st.
Posted Jun 23, 2025 - 16:16 EDT
This scheduled maintenance affected: eBill/TouchNet and StarRez.