DegreeWorks : College of Charleston Service Degradation

Identified

DegreeWorks is continuing to experience issues. We're working to identify the root cause further, but the system may be intermittent during this time.
Posted Jun 09, 2026 - 15:09 EDT

Monitoring

A fix has been implemented and performance is being monitored. Apologies for the inconvenience- if you experience any issues, please report them to help.charleston.edu.
Posted Jun 09, 2026 - 12:30 EDT

Identified

We're applying another fix to the system and DGW may be intermittently available as a result. We'll update once fully back up.
Posted Jun 09, 2026 - 11:53 EDT

Monitoring

DegreeWorks has been restored. We will be monitoring traffic to ensure the application remains available.
Posted Jun 09, 2026 - 09:13 EDT

Identified

DegreeWorks may be slow to load or produce errors this AM- we are investigating.
Posted Jun 09, 2026 - 08:46 EDT

Monitoring

DegreeWorks has been restored, but we are monitoring the system for any further issues.
Posted Jun 08, 2026 - 14:14 EDT

Investigating

We are currently experiencing a degraded level of service with DegreeWorks.

Our team is working to identify the root cause and implement a solution.
Posted Jun 08, 2026 - 14:02 EDT
This incident affects: DegreeWorks.