Get webhook notifications whenever College of Charleston System Status creates an incident, updates an incident, resolves an incident or changes a component status.
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jun 24, 2025 - 20:00 EDT
Scheduled
The Division of Information Technology would like to inform you of the listed maintenance interruptions at the date and time referenced above. The Wired Network will be unavailable during a Scheduled Maintenance Firmware Upgrade.
At The following locations:
School of Sciences and Mathematics Building - 202 Calhoun St, Charleston, SC 29401
The following services will be disrupted:
- Wired Network - VOIP - Security Cameras - Access Control - Cougar Card Readers - Digital Signage - Audio Visual Services - Printers - CMI
Posted Jun 18, 2025 - 12:48 EDT
This scheduled maintenance affected: Network-Wired (Wired Network).