People Admin - College of Charleston Service Disruption

Resolved

This incident has been resolved.
Posted Aug 20, 2025 - 09:30 EDT

Investigating

We are currently experiencing a service disruption with the performance module of PeopleAdmin (jobs.cofc.edu/portal).

PeopleAdmin is working to identify the root cause and implement a solution.
Posted Aug 18, 2025 - 12:00 EDT
This incident affected: PeopleAdmin.