DegreeWorks Service Disruption

Resolved

DegreeWorks has been restored and is operating normally.
Posted Jan 11, 2026 - 22:07 EST

Monitoring

An issue with the system has been identified and a fix has been implemented- system access has been restored. We are monitoring for the root cause and will provide any updates if further downtime is expected.
Posted Jan 10, 2026 - 22:29 EST

Investigating

We received reports of a service disruption with DegreeWorks.

Our team is working to identify the root cause and implement a solution as needed. Users may be unable to load DegreeWorks Dashboard at this time or see a connection error at launch.

We will send an additional update once more information is available.
Posted Jan 10, 2026 - 20:56 EST
This incident affected: DegreeWorks.