Get webhook notifications whenever College of Charleston System Status creates an incident, updates an incident, resolves an incident or changes a component status.
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jul 25, 2026 - 09:00 EDT
Scheduled
07-25-2026, 9am - Noon
The Division of Information Technology would like to inform you of the upcoming scheduled network outages. The wireless and wired networks will be intermittent or unavailable during a scheduled equipment upgrade.
The following locations: - Harbor Walk - 360 Concord St, Charleston, SC 29401 - Riley Center - 176 Lockwood Dr, Charleston, SC 29403 - Grice Marine Laboratory - Fort Johnson Rd, Charleston, SC 29412 - Center of Intentionality - 159 Rutledge Ave, Charleston, SC 29403 - Patriots Point Sports Complex - 85 Patriots Point Rd, Mt Pleasant, SC 29464 - Central Stores - 4750 Goer Dr, North Charleston, SC 29406 - College of Charleston Stono - Dixie Plantation Rd, Hollywood, SC 29449
The following services will be disrupted: - Wired Network - Wireless Network - Eduroam Wireless - CofC-guest wireless - VOIP - desk phones - Cougar Card Readers - Digital Signage - Audio Visual Services - Printers - CMI
Posted Jul 06, 2026 - 10:39 EDT
This scheduled maintenance affected: Network-Wired (Wired Network) and Network-Wireless (Wireless Network (eduroam), Wireless Network (CofC-Guest)).