JCL Long and surrounding area network : College of Charleston Service Disruption

Resolved

This incident has been resolved.
Posted Jul 29, 2026 - 08:36 EDT

Identified

We are currently experiencing a service disruption with the network at JC Long and surrounding areas.

Our Networking team is working to identify the root cause and implement a solution.

We will send an additional update in 1 hour.
Posted Jul 29, 2026 - 07:29 EDT
This incident affected: Network-Wired (Wired Network) and VOIP / Segra Unify.