Beatty Center School of Business - Wired Network Maintenance Upgrade

Scheduled for Dec 15, 07:00 EST  -  Dec 17, 07:00 EST

Update

We will be undergoing scheduled maintenance during this time.
Posted Dec 04, 2025 - 13:29 EST

Scheduled

12-15-2025, 7am through 12-16-2025, 7pm



The Division of Information Technology would like to inform you of the listed maintenance interruptions at the date and time referenced above. The Wired Network will be unavailable during a scheduled maintenance equipment upgrade. This will not impact the wireless network. This will not impact the Tate Center or JC Long.


At The following locations:

-Beatty Center School of Business - College of Charleston - 5 Liberty St, Charleston, SC 29401


The following services will be disrupted:

- Wired Network
- VOIP
- Cougar Card Readers
- Digital Signage
- Audio Visual Services
- Printers
- CMI
Posted Nov 11, 2025 - 15:21 EST
This scheduled maintenance affects: Network-Wired (Wired Network).