Outage: Emergency Maintenance - Wells Fargo Auditorium

Resolved

This incident has been resolved.
Posted Nov 24, 2025 - 11:52 EST

Investigating

Due to a power outage, we are currently experiencing a service disruption with Beatty Center - Wells Fargo Auditorium.

Our networking team is working to identify the root cause and implement a solution.
Posted Nov 24, 2025 - 08:23 EST
This incident affected: Network-Wired (Wired Network).