Banner Document Manager : College of Charleston Service Disruption

Resolved

BDM services have been restarted and are functioning normally again.
Posted Nov 24, 2025 - 09:56 EST

Investigating

We are currently experiencing a service disruption with Banner Document Manager (BDM).

Our Applications team is working to identify the root cause and implement a solution.
Posted Nov 24, 2025 - 09:22 EST
This incident affected: Banner (Banner Document Management).