DegreeWorks Outage

Resolved

Monitoring shows continued normal health for DegreeWorks. This incident is considered resolved, but if you experience any new issues, please report them to the IT Service Desk (help.charleston.edu).
Posted Mar 16, 2026 - 15:20 EDT

Monitoring

DegreeWorks access has been restored. We are reviewing the system to identify any further issues, as well as monitoring to ensure the system remains OK. If you continue to experience any issues, please reach out to the IT Service Desk directly (help.charleston.edu).
Posted Mar 16, 2026 - 08:27 EDT

Investigating

DegreeWorks is currently experiencing a major outage. We are currently investigating this issue.
Posted Mar 16, 2026 - 07:59 EDT
This incident affected: DegreeWorks.