MyPortal Outage

Resolved

https://status.exlibrisgroup.com/system_status showing that no system is reporting an issue. March 1 maintenance is completed.
Posted Mar 03, 2026 - 10:21 EST

Identified

ExLibris (the host of CampusM / MyPortal) is experiencing multiple outages as reported on their system status page at https://status.exlibrisgroup.com/system_status. MyPortal service may be degraded until a solution is implemented on their end.
Posted Feb 25, 2026 - 20:40 EST
This incident affected: MyPortal / CampusM.