CougarConnect : College of Charleston Service Disruption

Resolved

A fix has been implemented and Anthology are monitoring the results. You can follow their status at https://status.campuslabs.com/.
Posted Nov 24, 2025 - 11:34 EST

Monitoring

Monitoring - A fix has been implemented and Anthology are monitoring the results.
Posted Nov 19, 2025 - 14:57 EST

Investigating

We are currently experiencing a service disruption with CougarConnect.

Anthology is working to identify the root cause and implement a solution.

You can see their status at https://status.campuslabs.com/.
Posted Nov 19, 2025 - 12:00 EST
This incident affected: Cougar Connect (Anthology Engage).