Partial Elevator Phones Outages

Resolved

This incident has been resolved.
Posted Jul 30, 2026 - 07:34 EDT

Identified

We are currently repairing a communication issue with the elevators located in Jewish Studies (96 Wentworth St), Liberty Street Residence Hall (8 Liberty St), Robert Scott Small Building (College Way), School of Education (88 Wentworth) and McConnell Hall (111 Wentworth St). The phones in these elevators will not function while repairs are taking place.
Posted Jul 29, 2026 - 15:29 EDT
This incident affected: VOIP / Segra Unify.