Get webhook notifications whenever College of Charleston System Status creates an incident, updates an incident, resolves an incident or changes a component status.
We've received no further reports of issues since Microsoft applied a fix. At this time, the earlier issues are considered resolved. If you run into any further issues, please reach out to the IT Service Desk directly (help.charleston.edu).
Posted Mar 06, 2026 - 16:16 EST
Monitoring
Microsoft has identified the cause of the earlier service performance issues and have applied a fix within their systems. Internal CofC testing shows performance has been restored. If you continue to experience any further issues, please report them to the IT Service Desk (help.charleston.edu).
Posted Mar 06, 2026 - 13:27 EST
Investigating
The College has been made aware that our vendor Microsoft may be experiencing disruption with certain Microsoft 365 services- initial reports have noted issues with file access in Sharepoint/Teams and OneDrive. This may manifest as links not opening or errors such as "There was a problem reaching this app." We are confirming issues and any remediation steps with the vendor- the College will provide further details as they are provided by Microsoft.